const regex = /(?<=_)(\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=_)(\\d+$)', 'gm')
const str = `I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);