# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=_)(\d+$)//gm;t' <<< "I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420"