$re = '/(?<=_)(\d+$)/m';
$str = 'I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;