using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_)(\d+$)";
string substitution = @"";
string input = @"I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}