// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?").unwrap();
let string = "172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}