use strict;
my $str = '172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g';
my $regex = qr/(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";