# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?"
test_str = ("172.15.3\n\n"
"g-g.fr\n"
"http://www.google.com\n"
"google.fr\n"
"com.google.fr/test/\n"
"google.fr/test.html\n"
"g.g.g/g.g")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.