# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\\/.*)?//mg;t' <<< "172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g"