$re = '/(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?/m';
$str = '172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;