const regex = /(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-zA-Z]*\\.)+([a-zA-Z]+)(?:\\\/.*)?', 'mg')
const str = `172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);