import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-zA-Z]*\\.)+([a-zA-Z]+)(?:\\/.*)?";
final String string = "172.15.3\n\n"
+ "g-g.fr\n"
+ "http://www.google.com\n"
+ "google.fr\n"
+ "com.google.fr/test/\n"
+ "google.fr/test.html\n"
+ "g.g.g/g.g";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}