import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(?<=href=")(.+)(?="(( [a-z]+=)|>))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085" title="Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic">
<a href="/2-In-1-Notebook/"U729X-12-5""-FHD-I7-8665U-16GB-SSD-512G/p/10257105">
<a href="/2-In-1-Notebook/"U729X-12-5""-FH D-I7-8665U-16GB-SSD-512G/p/10257105">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)