using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href="")(.+)(?=""(( [a-z]+=)|>))";
string input = @"<a href=""/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085"" title=""Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic"">
<a href=""/2-In-1-Notebook/""U729X-12-5""-FHD-I7-8665U-16GB-SSD-512G/p/10257105"">
<a href=""/2-In-1-Notebook/""U729X-12-5""-FH D-I7-8665U-16GB-SSD-512G/p/10257105"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}