const regex = /(?<=href=")(.+)(?="(( [a-z]+=)|>))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=href=")(.+)(?="(( [a-z]+=)|>))', 'gm')
const str = `<a href="/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085" title="Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic">
<a href="/2-In-1-Notebook/"U729X-12-5""-FHD-I7-8665U-16GB-SSD-512G/p/10257105">
<a href="/2-In-1-Notebook/"U729X-12-5""-FH D-I7-8665U-16GB-SSD-512G/p/10257105">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}