# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=href=\")(.+)(?=\"(( [a-z]+=)|>))"
test_str = ("<a href=\"/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085\" title=\"Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic\">\n\n"
"<a href=\"/2-In-1-Notebook/\"U729X-12-5\"\"-FHD-I7-8665U-16GB-SSD-512G/p/10257105\">\n\n"
"<a href=\"/2-In-1-Notebook/\"U729X-12-5\"\"-FH D-I7-8665U-16GB-SSD-512G/p/10257105\">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.