import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=\")(.+)(?=\"(( [a-z]+=)|>))";
final String string = "<a href=\"/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085\" title=\"Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic\">\n\n"
+ "<a href=\"/2-In-1-Notebook/\"U729X-12-5\"\"-FHD-I7-8665U-16GB-SSD-512G/p/10257105\">\n\n"
+ "<a href=\"/2-In-1-Notebook/\"U729X-12-5\"\"-FH D-I7-8665U-16GB-SSD-512G/p/10257105\">";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}