re = /(?<=href=")(.+)(?="(( [a-z]+=)|>))/m
str = '<a href="/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085" title="Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic">
<a href="/2-In-1-Notebook/"U729X-12-5""-FHD-I7-8665U-16GB-SSD-512G/p/10257105">
<a href="/2-In-1-Notebook/"U729X-12-5""-FH D-I7-8665U-16GB-SSD-512G/p/10257105">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end