use strict;
my $str = '<a href="/2-In-1-Notebook/Lati-7400-2in1-Ci5-8GB-W10P-3Y-Basic/p/10270085" title="Dell, Lati 7400 2in1/Ci5/8GB/W10P/3Y Basic">
<a href="/2-In-1-Notebook/"U729X-12-5""-FHD-I7-8665U-16GB-SSD-512G/p/10257105">
<a href="/2-In-1-Notebook/"U729X-12-5""-FH D-I7-8665U-16GB-SSD-512G/p/10257105">';
my $regex = qr/(?<=href=")(.+)(?="(( [a-z]+=)|>))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}