re = /^\s*(?:[a-z]{2,}\.\s*)?(?:[a-zñ]{2,}\s*[a-zñ ]*,\s*[a-zñ]+\s*[a-zñ ]*(?:[a-zñ]\.?\s*){0,3}|[a-zñ]+\s*[a-zñ ]*\s+(?:[a-zñ]\.?\s*){0,3}[a-zñ]{2,}\s*[a-zñ ]*)\s*(?:[a-zñ., ])*$/im
str = '1
Christopher Quimpo
Christopher P. Quimpo
Engr. Christopher P. Quimpo
Z G. Gono
Qu, C
Engr. Q, C
Christopher Quimpo
1
Christopher
1
Q C
1'
subst = 'col.Add "$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result