import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:[a-z]{2,}\\.\\s*)?(?:[a-zñ]{2,}\\s*[a-zñ ]*,\\s*[a-zñ]+\\s*[a-zñ ]*(?:[a-zñ]\\.?\\s*){0,3}|[a-zñ]+\\s*[a-zñ ]*\\s+(?:[a-zñ]\\.?\\s*){0,3}[a-zñ]{2,}\\s*[a-zñ ]*)\\s*(?:[a-zñ., ])*$";
final String string = "1\n"
+ "Christopher Quimpo\n"
+ "Christopher P. Quimpo\n"
+ "Engr. Christopher P. Quimpo\n"
+ "Z G. Gono\n"
+ "Qu, C\n"
+ "Engr. Q, C\n"
+ "Christopher Quimpo\n"
+ "1\n"
+ "Christopher\n"
+ "1\n"
+ "Q C\n"
+ "1";
final String subst = "col.Add \"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}