#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^\s*(?:[a-z]{2,}\.\s*)?(?:[a-zñ]{2,}\s*[a-zñ ]*,\s*[a-zñ]+\s*[a-zñ ]*(?:[a-zñ]\.?\s*){0,3}|[a-zñ]+\s*[a-zñ ]*\s+(?:[a-zñ]\.?\s*){0,3}[a-zñ]{2,}\s*[a-zñ ]*)\s*(?:[a-zñ., ])*$"
Local $sString = "1" & @CRLF & _
"Christopher Quimpo" & @CRLF & _
"Christopher P. Quimpo" & @CRLF & _
"Engr. Christopher P. Quimpo" & @CRLF & _
"Z G. Gono" & @CRLF & _
"Qu, C" & @CRLF & _
"Engr. Q, C" & @CRLF & _
"Christopher Quimpo" & @CRLF & _
"1" & @CRLF & _
"Christopher" & @CRLF & _
"1" & @CRLF & _
"Q C" & @CRLF & _
"1"
Local $sSubst = "col.Add "$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)