const regex = /^\s*(?:[a-z]{2,}\.\s*)?(?:[a-zñ]{2,}\s*[a-zñ ]*,\s*[a-zñ]+\s*[a-zñ ]*(?:[a-zñ]\.?\s*){0,3}|[a-zñ]+\s*[a-zñ ]*\s+(?:[a-zñ]\.?\s*){0,3}[a-zñ]{2,}\s*[a-zñ ]*)\s*(?:[a-zñ., ])*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:[a-z]{2,}\\.\\s*)?(?:[a-zñ]{2,}\\s*[a-zñ ]*,\\s*[a-zñ]+\\s*[a-zñ ]*(?:[a-zñ]\\.?\\s*){0,3}|[a-zñ]+\\s*[a-zñ ]*\\s+(?:[a-zñ]\\.?\\s*){0,3}[a-zñ]{2,}\\s*[a-zñ ]*)\\s*(?:[a-zñ., ])*$', 'gim')
const str = `1
Christopher Quimpo
Christopher P. Quimpo
Engr. Christopher P. Quimpo
Z G. Gono
Qu, C
Engr. Q, C
Christopher Quimpo
1
Christopher
1
Q C
1`;
const subst = `col.Add "$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);