# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*(?:[a-z]{2,}\.\s*)?(?:[a-zñ]{2,}\s*[a-zñ ]*,\s*[a-zñ]+\s*[a-zñ ]*(?:[a-zñ]\.?\s*){0,3}|[a-zñ]+\s*[a-zñ ]*\s+(?:[a-zñ]\.?\s*){0,3}[a-zñ]{2,}\s*[a-zñ ]*)\s*(?:[a-zñ., ])*$/col.Add "$1"/gim;t' <<< "1
Christopher Quimpo
Christopher P. Quimpo
Engr. Christopher P. Quimpo
Z G. Gono
Qu, C
Engr. Q, C
Christopher Quimpo
1
Christopher
1
Q C
1"