using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:[a-z]{2,}\.\s*)?(?:[a-zñ]{2,}\s*[a-zñ ]*,\s*[a-zñ]+\s*[a-zñ ]*(?:[a-zñ]\.?\s*){0,3}|[a-zñ]+\s*[a-zñ ]*\s+(?:[a-zñ]\.?\s*){0,3}[a-zñ]{2,}\s*[a-zñ ]*)\s*(?:[a-zñ., ])*$";
string substitution = @"col.Add ""$1""";
string input = @"1
Christopher Quimpo
Christopher P. Quimpo
Engr. Christopher P. Quimpo
Z G. Gono
Qu, C
Engr. Q, C
Christopher Quimpo
1
Christopher
1
Q C
1";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}