import Foundation
let pattern = #"(<a href=".*(/media/video/\d+/)"*[^>]*>([^<]+)</a>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="videoTitle"><a href="/media/video/1234/" title='ddd "da"'>
bla lba
</a></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}