$re = '/(<a href=".*(/media/video/\d+/)"*[^>]*>([^<]+)</a>)/';
$str = '<div class="videoTitle"><a href="/media/video/1234/" title=\'ddd "da"\'>
bla lba
</a></div>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;