package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a href=".*(/media/video/\d+/)"*[^>]*>([^<]+)</a>)`)
var str = []byte(`<div class="videoTitle"><a href="/media/video/1234/" title='ddd "da"'>
bla lba
</a></div>`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}