re = /(<a href=".*(\/media\/video\/\d+\/)"*[^>]*>([^<]+)<\/a>)/
str = '<div class="videoTitle"><a href="/media/video/1234/" title=\'ddd "da"\'>
bla lba
</a></div>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result