using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a href="".*(/media/video/\d+/)""*[^>]*>([^<]+)</a>)";
string substitution = @"";
string input = @"<div class=""videoTitle""><a href=""/media/video/1234/"" title='ddd ""da""'>
bla lba
</a></div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}