// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a href=".*(/media/video/\d+/)"*[^>]*>([^<]+)</a>)"#).unwrap();
let string = "<div class=\"videoTitle\"><a href=\"/media/video/1234/\" title='ddd \"da\"'>
bla lba
</a></div>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}