// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=".[^"]*facebook\.com\/(.[^"]*)"#).unwrap();
let string = "<div class=\"fb-page\" data-href=\"https://www.facebook.com/dreamsportingtrips\" data-tabs=\"timeline\" data-small-header=\"false\" data-adapt-container-width=\"true\" data-hide-cover=\"false\" data-show-facepile=\"true\"><div class=\"fb-xfbml-parse-ignore\"><blockquote cite=\"https://www.facebook.com/dreamsportingtrips\"><a href=\"https://www.facebook.com/dreamsportingtrips\">Dream Sporting Trips</a></blockquote></div></div>
<p>This works for links to facebook on images, or facebook widgets, etc</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}