import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\".[^\"]*facebook\\.com\\/(.[^\"]*)";
final String string = "<div class=\"fb-page\" data-href=\"https://www.facebook.com/dreamsportingtrips\" data-tabs=\"timeline\" data-small-header=\"false\" data-adapt-container-width=\"true\" data-hide-cover=\"false\" data-show-facepile=\"true\"><div class=\"fb-xfbml-parse-ignore\"><blockquote cite=\"https://www.facebook.com/dreamsportingtrips\"><a href=\"https://www.facebook.com/dreamsportingtrips\">Dream Sporting Trips</a></blockquote></div></div>\n"
+ "<p>This works for links to facebook on images, or facebook widgets, etc</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}