use strict;
my $str = '<div class="fb-page" data-href="https://www.facebook.com/dreamsportingtrips" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/dreamsportingtrips"><a href="https://www.facebook.com/dreamsportingtrips">Dream Sporting Trips</a></blockquote></div></div>
<p>This works for links to facebook on images, or facebook widgets, etc</p>';
my $regex = qr/href=".[^"]*facebook\.com\/(.[^"]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}