const regex = /href=".[^"]*facebook\.com\/(.[^"]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=".[^"]*facebook\\.com\\\/(.[^"]*)', 'g')
const str = `<div class="fb-page" data-href="https://www.facebook.com/dreamsportingtrips" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/dreamsportingtrips"><a href="https://www.facebook.com/dreamsportingtrips">Dream Sporting Trips</a></blockquote></div></div>
<p>This works for links to facebook on images, or facebook widgets, etc</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}