using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href="".[^""]*facebook\.com\/(.[^""]*)";
string input = @"<div class=""fb-page"" data-href=""https://www.facebook.com/dreamsportingtrips"" data-tabs=""timeline"" data-small-header=""false"" data-adapt-container-width=""true"" data-hide-cover=""false"" data-show-facepile=""true""><div class=""fb-xfbml-parse-ignore""><blockquote cite=""https://www.facebook.com/dreamsportingtrips""><a href=""https://www.facebook.com/dreamsportingtrips"">Dream Sporting Trips</a></blockquote></div></div>
<p>This works for links to facebook on images, or facebook widgets, etc</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}