#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href=".[^"]*facebook\.com\/(.[^"]*)"
Local $sString = "<div class="fb-page" data-href="https://www.facebook.com/dreamsportingtrips" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/dreamsportingtrips"><a href="https://www.facebook.com/dreamsportingtrips">Dream Sporting Trips</a></blockquote></div></div>" & @CRLF & _
"<p>This works for links to facebook on images, or facebook widgets, etc</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")