$re = '/href=".[^"]*facebook\.com\/(.[^"]*)/';
$str = '<div class="fb-page" data-href="https://www.facebook.com/dreamsportingtrips" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/dreamsportingtrips"><a href="https://www.facebook.com/dreamsportingtrips">Dream Sporting Trips</a></blockquote></div></div>
<p>This works for links to facebook on images, or facebook widgets, etc</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);