// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)").unwrap();
let string = " إيجاد رابط ضمن أفراد الفريق
العمل الجماعي";
let substitution = "<i>$1</i>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}