const regex = /((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[\\u0600-\\u06ff])*(?:\\u0639\\u0645|\\u0636)(?:[\\u0600-\\u06ff])*)', 'gi')
const str = ` إيجاد رابط ضمن أفراد الفريق
العمل الجماعي`;
const subst = `<i>$1</i>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);