package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:[\u0600-\u06ff])*(?:\u0639\u0645|\u0636)(?:[\u0600-\u06ff])*)`)
var str = ` إيجاد رابط ضمن أفراد الفريق
العمل الجماعي`
var substitution = "<i>$1</i>"
fmt.Println(re.ReplaceAllString(str, substitution))
}