import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[\\u0600-\\u06ff])*(?:\\u0639\\u0645|\\u0636)(?:[\\u0600-\\u06ff])*)";
final String string = " إيجاد رابط ضمن أفراد الفريق \n"
+ "العمل الجماعي";
final String subst = "<i>$1</i>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}