re = /(?=(<picture>))(\w|\W)*(?<=<\/picture>)/m
str = '<!DOCTYPE html>
<html lang="en">
<head>
<title>Title</title>
</head>
<body>
<picture>
<source srcset="mobile.png" ></source>
<source srcset="tablet.png" ></source>
<source srcset="desktop.png" ></source>
<img srcset="default.png">
</picture>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end