import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(<picture>))(\\w|\\W)*(?<=<\\/picture>)";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ "<head>\n"
+ " <title>Title</title>\n"
+ "</head>\n"
+ "<body>\n"
+ " <picture>\n"
+ " <source srcset=\"mobile.png\" ></source>\n"
+ " <source srcset=\"tablet.png\" ></source>\n"
+ " <source srcset=\"desktop.png\" ></source>\n"
+ " <img srcset=\"default.png\">\n"
+ " </picture>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}