const regex = /(?=(<picture>))(\w|\W)*(?<=<\/picture>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(<picture>))(\\w|\\W)*(?<=<\\\/picture>)', 'gm')
const str = `<!DOCTYPE html>
<html lang="en">
<head>
<title>Title</title>
</head>
<body>
<picture>
<source srcset="mobile.png" ></source>
<source srcset="tablet.png" ></source>
<source srcset="desktop.png" ></source>
<img srcset="default.png">
</picture>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}