#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(<picture>))(\w|\W)*(?<=<\/picture>)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
"<head>" & @CRLF & _
" <title>Title</title>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" <picture>" & @CRLF & _
" <source srcset="mobile.png" ></source>" & @CRLF & _
" <source srcset="tablet.png" ></source>" & @CRLF & _
" <source srcset="desktop.png" ></source>" & @CRLF & _
" <img srcset="default.png">" & @CRLF & _
" </picture>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")