use strict;
my $str = '<!DOCTYPE html>
<html lang="en">
<head>
<title>Title</title>
</head>
<body>
<picture>
<source srcset="mobile.png" ></source>
<source srcset="tablet.png" ></source>
<source srcset="desktop.png" ></source>
<img srcset="default.png">
</picture>
</body>
</html>';
my $regex = qr/(?=(<picture>))(\w|\W)*(?<=<\/picture>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}