$re = '/(?=(<picture>))(\w|\W)*(?<=<\/picture>)/m';
$str = '<!DOCTYPE html>
<html lang="en">
<head>
<title>Title</title>
</head>
<body>
<picture>
<source srcset="mobile.png" ></source>
<source srcset="tablet.png" ></source>
<source srcset="desktop.png" ></source>
<img srcset="default.png">
</picture>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);