using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(<picture>))(\w|\W)*(?<=<\/picture>)";
string input = @"<!DOCTYPE html>
<html lang=""en"">
<head>
<title>Title</title>
</head>
<body>
<picture>
<source srcset=""mobile.png"" ></source>
<source srcset=""tablet.png"" ></source>
<source srcset=""desktop.png"" ></source>
<img srcset=""default.png"">
</picture>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}