import Foundation
let pattern = #"(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feat(VLOT-1355): такое вот описание
feat(VLOT-1355,VLOT-1440): вот такое вот описание
feat: вот такое вот описание
bugfix(VLOT-1355): вот такая бага
bugfix: вот еще бага
bugfix или так
feat чето там
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)