package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:feat|bugfix)(:?\((?:VLOT-\d+\,?)+\))?:\s`)
var str = `feat(VLOT-1355): такое вот описание
feat(VLOT-1355,VLOT-1440): вот такое вот описание
feat: вот такое вот описание
bugfix(VLOT-1355): вот такая бага
bugfix: вот еще бага
bugfix или так
feat чето там`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}